网络☞链路聚合

阅读量: zyh 2021-05-25 14:20:01
Categories: > Tags:

目的

扩宽网络,突破单路

例如原本是单路千兆,扩成双路并发千兆

文档里的聚合类型均为动态聚合

H3C交换机(副) - 其它交换机

# 创建连接其它交换机的聚合接口
# 聚合接口序号 1
# 聚合接口设置为 trunk 模式, 并允许所有 vlan 通过
# 聚合接口模式设置为动态聚合
interface Bridge-Aggregation 1
 port link-type trunk
 port trunk permit vlan all
 link-aggregation mode dynamic
 
# 添加普通端口 1-4 到聚合接口
# 设置普通端口为 trunk 模式,并允许所有 vlan 通过
interface range GigabitEthernet1/0/1 to GigabitEthernet1/0/4
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1

关于普通端口是否设置 link-type,很多文档里没有提及,但是我配置中,不设置网络就不通

若 H3C 连接的是终端,则将端口模式改为 access,并设置仅允许通过的 vlan

华为交换机(主) - 其它交换机

# 创建连接其它交换机的聚合接口
# 聚合接口序号1
# 聚合接口设置为 trunk 模式, 并允许所有 vlan 通过
# 聚合接口模式设置为动态聚合
interface Eth-Trunk 1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 mode lacp

# 添加普通端口 1-4 到聚合接口
# 设置普通端口的活动优先级为 100,默认端口优先级是30000+, 优先级数字越小,优先级越高
interface GigabitEthernet0/0/1
 eth-trunk 1
 lacp priority 100
interface GigabitEthernet0/0/2
 eth-trunk 1
 lacp priority 100
interface GigabitEthernet0/0/3
 eth-trunk 1
 lacp priority 100
interface GigabitEthernet0/0/4
 eth-trunk 1
 lacp priority 100

若华为连接的是终端,则将端口模式改为 access,并设置仅允许通过的 vlan

群辉

前提:

交换机一侧已经配置好了动态聚合

控制面板-网络-网络界面-新增-创建 Bond

  1. 设置聚合方式,选IEEE 802.3ad 动态 Link Aggregationl
  2. 选择参与聚合的网络端口
  3. 设定聚合接口的ip地址

保存设置后,群辉会重载。

如果不幸因配置故障,导致群辉无法访问,那么你可以通过群辉硬件上的 reset 按钮进行管理员账户和网络配置重置,需要注意的是,仅可按下4秒,在第一次听到滴声后,就立马松开。

vsphere vcenter

先看一个设置的拓扑,左边虚拟机16.50,默认只有一个虚拟网卡,右边lag1是一个上行聚合组

image-20210527180252600

登录 vsphere 网络控制台,点击网络,新建一个分布式虚拟交换机,期间所有属性全默认(名字你可以自己起,其它保持全默认就行)

image-20210525145742419

既然是一个虚拟交换机,那么肯定需要配置一个上联至物理交换机的聚合trunk链路(lag1)和下联虚拟机的聚合access链路(DportGroup-vlan2016)

创建上联至物理交换机的聚合trunk链路

选中所建立的 DSwitch - 配置 - LACP - 新建,创建虚拟交换机下的上联聚合接口lag1,lag1有4个端口,并且这4个端口对应4个宿主机网卡,负载平衡模式需要和物理交换机聚合接口设置的负载协议一致

假设这里都选择 src-dst-ip,即源和目标ip地址。

需要注意的是,华为交换机普通型号不支持增强负载方案,也就是不支持sport和dspot负载。例如S5700EI就不支持。

VLAN中继范围,我们选择中继所有,这个和物理交换机聚合接口设置保持一致即可。

image-20210525151556021

按照web页面的提示

image-20210525155005563

创建一个下行端口组,用于关联虚拟机的网卡

你有几个虚拟网卡,就开几个端口数,也可以多开,用不用看你自己。

VLAN ID就是指这个下行端口组允许通过的VLAN。

image-20210527182054562

将exsi物理主机加入到DSwitch,并将DSwitch的聚合接口里的端口与exsi物理网卡绑定

image-20210527175600067

选中所建立的 DSwitch - 右键 - 添加和管理主机 - 添加主机

在添加和管理主机-管理物理适配器中,选择物理网卡并绑定到虚拟交换机的上联链路聚合组ige1里的虚拟端口,随你怎么绑定,反正把你的物理网卡都绑定上即可。

其余的迁移虚拟机网络之类的可以先不做。

到此,DSwitch和物理交换机之间的聚合应该已经打通了。

在物理交换机那边查看聚合接口,确保所有参与聚合的端口都是 selected 状态。

将虚拟机网卡关联到虚拟交换机DSwitch的下行端口组

在本文档中,即将网络适配器关联到 DportGroup-vlan2016。

最后,在虚拟机网卡配置中,将网络适配器从VM Network改为下行端口组

image-20210525160148265

或者将虚拟机从 VM Network交换机迁出到 DSwitch 交换机

需要注意的是,这种方式会将虚拟机下所有虚拟网卡全部迁移。

image-20210525160429071

测试虚拟机的网卡速度

可以看到,已经突破了100MBps(聚合前,exsi宿主机到物理交换机之前是100MBps)

image-20210527181349144